Home > Network > Mikrotik Routeros v6 3G Modem ve Sms Konfigurasyonu

Mikrotik Routeros v6 3G Modem ve Sms Konfigurasyonu


Mikrotik ile mevcut hattnızı 3g modemle yedekleyebilir veya herhangi bir sorun oldugunda mevcut isp ile arasında ki baglantı kayboldugunda işlemci sistem durumu vs seyleri size sms üzerinden de bildirmesini saglayabilirsiniz.

Routerboard donanımınızın desteklediği 3g modem ve 3g minipci card listesine aşağıdaki linkten bakabilirsiniz.

http://wiki.mikrotik.com/wiki/Supported_Hardware#3G_cards_and_modems

Şimdi mikrotik üzerinde bulunan usb portuna 3g modemi taktıktan sonra

Usb portunu kontrol ediyoruz aygıtı tanımısmı

Default ta int ppp-out olarak gelir ve disable moddadır.

Enable etmek içinwinbox ile bağlandıktan sonra interface ppp-out enable

Şimdi 3g için gerekli ayarları yapıcaz

Baglı olduğu usb portu sectik apn kısmına mgb yazıcaksınız turkcell için

Ppp sekmesine geçip phone kısmına *99# dial command ATDT add default route işaretleyip

Şimdi status connected oldu baglanıp ip bilgilerini aldı

Şimdi firewall nat bir rule eklememiz lazım local network u burdan çıkarmak için

İp firewall nat

chain=srcnat action=masquerade src-address=10.10.10.0/24 out-interface=3G Modem log=no log-prefix=””

suan 3g üzerinden kullanıcılar hattı kullanabiliyor.

Şimdi sms ayarlarını yapalım

Tools-sms menüsü altından sms alımını etkinleştiriyoruz.

Şimdi bu hatta mesaj geldiğinde inbox kutusunda görebilirsiniz sms göndermek için secret belirleyip sadece her sms içinde o kodu yazarak da sms gönderebilirsiniz veya sadece belli numaralara izin verip o numaralardan gelen sms leri kabul edebiliriz.

Send sms menusunden sms gönderimi yapmak için

Şimdi sms kontrol edelim gelmişmi telefonumuza

Şimdi script ile track ettiğimiz bir ip down oldugunda bize bildirim göndermesini sağlayıcağız.

Bunun için tool menusu altında bulunan sms,netwatch da gerekli ayarları yapalım.

System script

Yeni bir script ekliyelim

/system script

add name=Gateway_Down owner=admin policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive source=

“tool sms send message=Mikrotik_Routeros_Bildirim_TT_Adsl_Gateway_Down phone-number=05XXXXXXXXX usb1″

Aynısını birde up oldugunda ki durum için yazıcagız

/system script

add name=Gateway_Up owner=admin policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive source=

” tool sms send message=Mikrotik_Routeros_Bildirim_TT_Adsl_Gateway_Up phone-number=05XXXXXXXXX usb1″

Şimdi tool menusu altında bulunan netwatch ile izliyeceğimiz ip adresini yazalım down olduktan 9 saniye sonra sms atıcak

Up ve down menuleri altına yazdığımız scriptleri göstricez status durumu down veya up oldugunda oan göre scripti çalıştıracak.

Down için

Şimdi test edelim ben firewall dan 195.175.39.39 için out yönünde bir drop rule ekledim kesinti olsun diye

Bildirim sms leri geldi

Advertisements
  1. No comments yet.
  1. No trackbacks yet.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google+ photo

You are commenting using your Google+ account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

%d bloggers like this: