Home > Network > Mikrotik Routeros v6 Snmp v3 Etkinleştirme ve Cacti ye Tanımlama

Mikrotik Routeros v6 Snmp v3 Etkinleştirme ve Cacti ye Tanımlama


Mikrotik üzerindeki herhangi bir interface in ,cpu memory ,veya queues ler e ait oid leri almayı snmp ayarlarını dogrulamayı,cacti ye mikrotik template eklemeyi cacti ye snmp v3 ile mikrotik üzerinden veri çekicez.

Router un durumu hakkında bilgi almak izlemek için snmp yi aktif etmek gerekiyor v1-v2 güvenlik olarak sadece comminity name kullanıyor snmpv3 de ise kullanıcı adı şifre ve şifreleme algoritmaları bulunmaktadır.

Terminal dan yapmak için

/snmp community set name=Istanbul (comminity name burda username )

security=private authentication-password=Emin.1234 authentication-protocol=SHA1(veya MD5)

encryption-password=Emin.2015 encryption-protocol=DES

read-access=yes write-access=no addresses=10.10.10.252 (Cacti server ip (sizdeki izleme programı ne ise onun ip adresini yazın (solarwinds,ipswitch whatsup gold,PRTG vs)

Arayüzden yapmak için winbox veya webfig den login olduktan sonra ip snmp menüsü altından gerekli tanımları yapıyoruz.

Snmp etkinleştirdikten sonra çalışıp çalışmadına bakalım

Paessler snmp tester tool u ile test edicem baglantıyı çok kullanıslı free bi tool bu arac ile de mikrotik üzerindeki interface lere ait oid leri çekebilirz veya mikrotik üzerinden de trafigini izlemek istediğimiz interface in oid değerini çekip buraya yazıp test edebiliriz.

İp kullanıcı adı şifre şifreleme algoritmalarını doru yazdıktan sonra start edip gelen bilgileri görüyoruz örneğin benim kullandıgım adsl hattı ether 1 de takılı sadece ona ait trafigi alıp real time izlemek istiyorsam scan interface sonucunda bulunan in,out değerini (SnmpTrafficGrapher vs ) bi toola yazarak anlık olarak da izliyebilirsiniz.

Bağlantı basarılı

snmp_v3_log

Mikrotik üzerinden bir interface ait oid değerini çekmek için ise

SnmpTrafficGrapher üzerinden realtime olarak izlemek istediğim int bytes-in,bytes-out değerini alıp

Yalnız bu program sadece v1,v2 de çalışır comminity name i yazıcaksınız v3 desteği yok 32 bittir.

Cacti üzerine mikrotik template tanımlamak için

Link deki template indirip.

Cacti ye import etmek için console import/export – import template

Router ı eklemek için console device add host template olarak mikrotik device seciyoruz.

Bilgileri eksizsiz olarak giriyoruz.

Verileri çekti şimdi graphs oluşturacagız .

İstediklerimizi secip create dedikten sonra isterseniz farklı bir tree altına alın veya defaultta kullanın

Verileri yavas yavas cekmeye başlamış.

Mikrotik tarafında firewall rule eklemeyide unutmayalım J

/ip firewall filter

add chain=input comment=”SNMP PORT 161 ALLOW” dst-port=161 in-interface=

“TTNET ADSL ” protocol=udp

Snmp trap için 162 porta da izin vermek gerekiyor.

Advertisements
  1. No comments yet.
  1. No trackbacks yet.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google+ photo

You are commenting using your Google+ account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

%d bloggers like this: